Note: The other languages of the website are Google-translated. Back to English

Excel'de virgülle ayrılmış liste içeren bir hücrede değer nasıl bulunur?

Bir sütununuzun Sales, 123, AAA gibi virgülle ayrılmış değerler içerdiğini varsayarsak ve şimdi virgülle ayrılmış hücrede 123 değerinin bulunup bulunmadığını bulmak istiyorsanız, nasıl yapabilirsiniz? Bu makale sorunu çözme yöntemini tanıtacaktır.

Formülü olan virgülle ayrılmış listeye sahip bir hücrede değer bulun


Formülü olan virgülle ayrılmış listeye sahip bir hücrede değer bulun

Aşağıdaki formül, Excel'de virgülle ayrılmış liste içeren bir hücrede değer bulmanıza yardımcı olabilir. Lütfen aşağıdaki işlemleri yapın.

1. Boş bir hücre seçin, formül girin =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") Formül Çubuğuna girin ve ardından Enter tuşuna basın. Ekran görüntüsüne bakın:

not: Formülde A2, hücrenin bulacağınız virgülle ayrılmış değerleri içermesidir.

2. Sonuç hücresini seçmeye devam edin ve tüm sonuçları almak için Dolgu Tutamaçını aşağı sürükleyin. Virgülle ayrılmış hücrelerde "123" değeri varsa, sonucu "Evet" olarak alırsınız; aksi takdirde sonucu "Hayır" olarak alırsınız. Ekran görüntüsüne bakın:


İlgili yazılar:


En İyi Ofis Üretkenliği Araçları

Kutools for Excel Sorunlarınızın Çoğunu Çözer ve Verimliliğinizi% 80 Artırır

  • Yeniden: Hızlıca yerleştirin karmaşık formüller, grafikler ve daha önce kullandığınız her şey; Hücreleri Şifrele şifre ile; Posta Listesi Oluşturun ve e-posta gönder ...
  • Süper Formül Çubuğu (birden çok metin ve formül satırını kolayca düzenleyin); Okuma Düzeni (çok sayıda hücreyi kolayca okuyun ve düzenleyin); Filtrelenmiş Aralığa Yapıştır...
  • Hücreleri / Satırları / Sütunları Birleştirme Veri kaybetmeden; Bölünmüş Hücre İçeriği; Yinelenen Satırları / Sütunları Birleştirme... Yinelenen Hücreleri Önleyin; Aralıkları Karşılaştır...
  • Yinelenen veya Benzersiz'i seçin Satırlar; Boş Satırları Seçin (tüm hücreler boştur); Süper Bul ve Bulanık Bul Birçok Çalışma Kitabında; Rastgele Seçim ...
  • Tam kopya Formül referansını değiştirmeden Birden Çok Hücre; Otomatik Referans Oluştur Birden Çok Sayfaya; Madde İşaretleri Ekle, Onay Kutuları ve daha fazlası ...
  • Metni Çıkar, Metin Ekle, Konuma Göre Kaldır, Alanı Kaldır; Sayfalama Alt Toplamları Oluşturma ve Yazdırma; Hücre İçeriği ve Yorumları Arasında Dönüştür...
  • Süper Filtre (filtre şemalarını kaydedin ve diğer sayfalara uygulayın); Gelişmiş Sıralama ay / hafta / gün, sıklık ve daha fazlasına göre; Özel Filtre kalın, italik ...
  • Çalışma Kitaplarını ve Çalışma Sayfalarını Birleştirin; Tabloları anahtar sütunlara göre birleştirin; Verileri Birden Çok Sayfaya Bölme; Toplu dönüştürme xls, xlsx ve PDF...
  • 300'den fazla güçlü özellik. Office / Excel 2007-2021 ve 365'i destekler. Tüm dilleri destekler. Kuruluşunuzda veya kuruluşunuzda kolay devreye alma. Tam özellikler 30 günlük ücretsiz deneme. 60 günlük para iade garantisi.
kte sekmesi 201905

Office Tab, Office'e Sekmeli Arayüz Getirir ve İşinizi Çok Daha Kolay Hale Getirir

  • Word, Excel, PowerPoint'te sekmeli düzenlemeyi ve okumayı etkinleştirin, Publisher, Access, Visio ve Project.
  • Yeni pencereler yerine aynı pencerenin yeni sekmelerinde birden çok belge açın ve oluşturun.
  • Üretkenliğinizi% 50 artırır ve her gün sizin için yüzlerce fare tıklamasını azaltır!
ofis tabanı
Yorumları sıralama ölçütü
Yorumlar (16)
Henüz derecelendirme yok. İlk değerlendiren siz olun!
Bu yorum sitedeki moderatör tarafından en aza indirildi
Herkese günaydın.Excel'de tek bir hücrede virgülle ayrılmış belirli değerlerin nasıl sayılacağına dair bir excel sorum var.15 içeren tek bir hücrede 15,215,15,155,45,1515,15'in sayısını saymak istiyorum sonuç 3. Excel'de herhangi bir formül var mı?
Bu yorum sitedeki moderatör tarafından en aza indirildi
Evet, Excel'de bunu sizin için yapabilecek bir fonksiyon var. Ancak, yukarıdaki problemde açıklandığı gibi, verilerinizde daha iyi doğruluk elde etmek için listenizin soluna ve sağına bir virgül ekleyin ve aramanıza ekleyin. Aşağıdaki örneğe bakın:
, 15,215,15,155,45,1515,15,
=EĞERSAY(A1, ",15,")
Bu formülün açıklaması şu şekildedir: =EĞERSAY(hücre numarası veya aralığı, aradığınız değer/sayıyor)
Daha iyi bir örneğe ihtiyacınız varsa bana bildirin.
Bu yorum sitedeki moderatör tarafından en aza indirildi
Merhaba!
Bu gerçekten harika bir formül, ama... kusuru var mı? ... nasıl çözeceğimi çözemiyorum. "Kusur" doğru kelime değil, ama doğru kelimeyi düşünemiyorum (Pazartesi saat 8:30).
Bir sayının herhangi bir bölümünü aradığınızda "evet" alırsınız. Yani, aşağıdakilerin tümü "evet" döndürür:
=EĞER(ESAYI(ARA(12,A2)),"evet","hayır")
=EĞER(ESAYI(ARA(23,A2)),"evet","hayır")
=EĞER(ESAYI(ARA(3,A2)),"evet","hayır")

Rakamları boşuna tırnak içine almayı denedim. Formül, örneğin tüm sayıların aynı uzunlukta olduğu kullanım durumu için mükemmel şekilde çalışır. Ancak, dizede görünen daha kısa bir sayı arıyorsanız, yanlış bir pozitif alırsınız.
"ARA" yerine daha gerçek bir alternatif var mı (yine kelime bu mu? haha)? 
Teşekkürler! 
Bu yorum sitedeki moderatör tarafından en aza indirildi
Merhaba Scott S., Tam diziyi mi arıyorsunuz?
Bu yorum sitedeki moderatör tarafından en aza indirildi
Merhaba, Kristal.
Evet, sanırım bunu ifade etmenin yolu bu. 
Geçerli çözüm, sayı dizisinin herhangi bir bölümü için "Evet" döndürecektir. Böylece 1, 2, 3, 12, 23 ve 123 sayıların tümü “Evet” olarak dönecektir. 
Bir dizi sayıyı arayacak ve tam bir eşleşme için "Evet" döndürecek bir çözüm bulmaya çalışıyorum. 
Bu yorum sitedeki moderatör tarafından en aza indirildi
Merhaba Scott S, Geri bildiriminiz için teşekkür ederiz. Çözümü henüz bulamadım ve bulursam size geri döneceğim.
Bu yorum sitedeki moderatör tarafından en aza indirildi
Bunun için bir çözüm buldum. Listenizin soluna ve sağına bir virgül eklerseniz ve onları (bir sandviç gibi) aramanıza dahil ederseniz, tam bir eşleşme bulmanızı sağlar. Aşağıdaki örnek:
, 123,231,321,122,321,1,2,3,23,
ARAMA(",23,")
Bu şekilde, aramayı listedeki girdinin bir parçası yerine bir virgülden diğerine eşleşmeye zorlar. Umarım aradığınız şey budur?
Bu yorum sitedeki moderatör tarafından en aza indirildi
Bir çözüm buldum. Listenizin soluna ve sağına bir virgül eklerseniz, arama işlevinin virgülden virgüle tam bir eşleşme bulması gerekir. Aşağıdaki örneğe bakın:
=EĞER(ESAYI(ARA(",12;",A2)),"evet","hayır")

, 312,123,10,112,126,
Aramayla eşleşen virgülden virgüle (,12,) değişen bir değişken olmadığı için bu false döndürür. 
Daha fazla açıklamaya ihtiyacınız varsa, bana bildirin ve daha iyi bir örnek yayınlayın. Patronum için bir raporu otomatikleştirirken de aynı sorunu yaşıyordum ve bir aydınlanma yaşadım. :)
Bu yorum sitedeki moderatör tarafından en aza indirildi
Hey, bunu hala çözemedim. Hala aynı sorunu yaşıyorum. formülde sayı kullanmak yerine hücre referansı kullanıyorum. örneğin, (1, 1)($J123)'de "25,29,200"(Q$2) için arama yapıyorsam, yine de bana EVET veriyor. Formül =EĞER(SAYIYSA(ARA(Q$1,$J2))"evet","hayır") şeklindedir.

Not: Büyük bir veri setim var her hücrenin başına ve sonuna virgül koyamıyorum. Bir çözümü takdir edecek
Bu yorum sitedeki moderatör tarafından en aza indirildi
Merhaba yardım edin

Excel'de A ve B sütunlu iki sütunlu bir tablom var, A altında bir değer var Örn. A2 Hücresi 1,2,2,1,2,1,2 vb. tüm hücrede 1 ve 2 ve başka bir sayı yok) ve A1'te 2 ve A3'te 1,1,1, A4'te 0 ve A5'da 2,2,2,2 var. B6'nin Asya olarak A20 değerini döndürmesini istiyorum , B2 Afrika, B2 Yok, B3 Amerika ve B4 Avrupa. if formülünü kullanabileceğimi düşündüm ama virgülle ayrılmış sayıları ve dönüş değerini tanıyamıyor). Lütfen yardım et
Bu yorum sitedeki moderatör tarafından en aza indirildi
Buna ne dersin lütfen, A'daki değerleri alıp C'deki rakamlarla eşitlemem ve B'deki değerleri virgülle ayırarak sırasıyla C'ye döndürmem gerekiyor.

Teşekkürler
Bu yorum sitedeki moderatör tarafından en aza indirildi
merhaba duncan,
365 için Excel kullanıyorsanız, aşağıdaki formül sorunu çözmenize yardımcı olabilir.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Bu formül yalnızca 365 için Excel'de çalışır. 365 için Excel dışındaki diğer Excel sürümleri için bunu işleyen bir formül bulamadım..
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
Bu yorum sitedeki moderatör tarafından en aza indirildi
Herkese selam, Virgülle ayrılmış birden fazla ülke içeren bir hücrem var.
Örnek : A2 hücre değeri (Hindistan, Japonya, Malezya, Büyük Çin)
Sütun G ülke adlarını içerir
Şimdi, G sütunundaki değeri A2 hücresindeki değerle karşılaştıran bir formül bulmam gerekiyor.
Değer eşleşirse, true döndürün, aksi takdirde False döndürün
Bu yorum sitedeki moderatör tarafından en aza indirildi
Merhaba Mohini Verma,
Formül aşağıdaki gibi değiştirilebilir:
=EĞER(SAYIYSA(ARA(G2,A2)),"DOĞRU","YANLIŞ")
Bu yorum sitedeki moderatör tarafından en aza indirildi
Hey, bunu hala çözemedim. Hala aynı sorunu yaşıyorum. formülde sayı kullanmak yerine hücre referansı kullanıyorum. örneğin, (1, 1)($J123)'de "25,29,200"(Q$2) için arama yapıyorsam, yine de bana EVET veriyor. Formül =EĞER(SAYIYSA(ARA(Q$1,$J2))"evet","hayır") şeklindedir.

Not: Büyük bir veri setim var her hücrenin başına ve sonuna virgül koyamıyorum. Bir çözümü takdir edecek
Bu yorum sitedeki moderatör tarafından en aza indirildi
Merhaba Hassam

Aşağıdaki formülü EĞER işlevi olmadan kullanmanız yeterlidir. Sayı tam olarak eşleşirse, sonucu alırsınız "DOĞRU", aksi takdirde sonucu alırsınız"YANLIŞ".
=SAYIYSA(BUL(",1,",","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
Buraya henüz hiç yorum yapılmamış
Lütfen yorum yazın
Misafir olarak yayınlama
×
Bu gönderiyi değerlendirin:
0   Karakterler
Önerilen Konumlar

Bizi takip et

Telif Hakkı © 2009 - www.extendoffice.com. | Tüm hakları Saklıdır. Tarafından desteklenmektedir ExtendOffice. | | | Site Haritası
Microsoft ve Office logosu, Microsoft Corporation'ın Amerika Birleşik Devletleri ve / veya diğer ülkelerdeki ticari markaları veya tescilli ticari markalarıdır.
Sectigo SSL ile korunmaktadır