Note: The other languages of the website are Google-translated. Back to English
Oturum aç  \/ 
x
or
x
Kaydol  \/ 
x

or

EXCEL COUNTIF işlevi – Boş olmayan, büyük/küçük olmayan veya belirli bir değer içeren hücreleri sayın

Bir Excel çalışma sayfasında çalışırken, boş veya boş olmayan hücreleri, belirli bir değerden büyük veya küçük hücreleri veya belirli bir metni içeren hücreleri saymak gibi hücre sayısını saymak, çoğu için ortak görevler olabilir. Biz. Bu hesaplamalarla başa çıkmak için Excel'deki COUNIT işlevi size bir iyilik yapabilir.

Excel'de EĞERSAY işlevinin sözdizimi

Boş veya boş olmayan hücreler için EĞERSAY işlevi

Belirli bir değerden küçük, büyük veya ona eşit hücreler için EĞERSAY işlevi

Hücreler için EĞERSAY işlevi belirli bir değer içeriyor


Excel'de EĞERSAY işlevinin sözdizimi

Excel'deki istatistiksel işlevlerden biri olan EĞERSAY, belirli bir aralıkta verilen ölçütleri karşılayan hücreleri sayar. EĞERSAY işlevinin sözdizimi şöyledir:

=COUNTIF(range, criteria)

Sözdizimi iki bağımsız değişken içerir – menzil ve kriterleri:

  • menzil: saymak istediğiniz hücre aralığını ifade eder.
  • kriterleri: hücreleri saymak için kullanmak istediğiniz koşulu belirtir. Örneğin, seçtiğiniz aralıkta 80'e eşit veya daha büyük değerlere sahip hücreleri aramak için ölçüt olarak ">=80" kullanabilirsiniz.

İşlevi Excel'de uygulamak için şunu yazmalısınız = EĞERSAY (aralık, ölçüt) bir hedef hücrede. Örneğin, =EĞERSAY(A1:B8;">=80").

EĞERSAY işlevi, saymak istediğiniz hücre sayısı olan sayısal bir değer döndürür.

EĞERSAY işlevini daha net anladığımıza göre, şimdi bazı gerçek örneklere geçelim.


Boş veya boş olmayan hücreler için EĞERSAY işlevi

Örneğin, metin, Boole değerleri (DOĞRU ve YANLIŞ), sayılar, tarihler ve hatalar gibi farklı veri türleri içeren bir hücre listem var. Belirttiğiniz aralıkta hangi veri türleri bulunursa bulunsun, yalnızca boş veya boş olmayan hücreleri saymak için evrensel bir EĞERSAY formülü var mı?

sayma boş daha az 1

EĞERSAY işleviyle boş hücreleri sayın

Şimdi size EĞERSAY formülünü tanıtayım. Formül ile, aralıkta kaç tane veri türü olursa olsun, size boş hücrelerin tam ve doğru sayısını söyleyecektir:

=COUNTIF(range,"")
Not: Tırnak içinde metin yoktur, yani saymak istediğiniz hücreler boştur.

EĞERSAY işlevini boş hücreleri saymak için kullanmak için formülü yazın =EĞERSAY(A1:A9,"") bir hedef hücrede, ardından ENTER:

sayma boş daha az 2 >>> sayma boş daha az 3

Excel'de ayrıca denilen bir fonksiyon vardır. COUNTBOLANK, belirtilen aralıktaki boş hücrelerin sayısını döndürür. Bunun sözdizimi = COUNTBLANK (aralık). Yukarıdaki örnek için şu formülü kullanabilirsiniz: =COUNTBOŞ(A1:A9).


EĞERSAY işleviyle boş olmayan hücreleri sayın

Boş olmayan hücreleri saymak için, burada size formülü göstereyim:

=COUNTIF(range,"<>")
Not: <> Excel'de şu anlama gelir eşit değil. Yani yukarıdaki formül boş olmayan veya boş olmayan tüm hücreleri sayar.

EĞERSAY işlevini boş olmayan hücreleri saymak için kullanmak için formülü yazın =EĞERSAY(A1:A9;"<>") bir hedef hücrede, ardından ENTER:

sayma boş daha az 4 >>> sayma boş daha az 5

Excel'de ayrıca denilen bir fonksiyon vardır. COUNTA, belirtilen aralıktaki herhangi bir değeri içeren hücre sayısını döndürür. Bunun sözdizimi =COUNTA(aralık). Yukarıdaki örnek için şu formülü kullanabilirsiniz: = COUNTA (A1: A9).

Ancak, yalnızca metin içeren hücreleri saymak ve Boole değerlerini (DOĞRU ve YANLIŞ), sayıları, tarihleri ​​veya hataları hariç tutmak istiyorsanız, lütfen aşağıdaki formülü kullanın:

=COUNTIF(A1:A9,"*")
Note: A single asterisk (*) matches only the value in a text form.

sayma boş daha az 6 >>> sayma boş daha az 7

İki tıklamayla boş olmayan hücreleri sayın

Eğer senve Kutools for Excel Excel'inize yüklü, Boş Olmayan Hücreleri Seçin özelliği, boş olmayan tüm hücreleri bir kerede seçebilir ve ihtiyacınız olan sayıyı alabilirsiniz.

1. Kutools Excel'de sekme, bul seçmekVe tıklama Boş Olmayan Hücreleri Seçin açılır listede. Ekran görüntüsüne bakın:

sayma boş daha az 8

2. Tüm boş olmayan hücreler seçilecek ve aşağıda gösterilen ekran görüntüsü gibi size boş olmayan hücrelerin sayısını söyleyen bir bilgi istemi kutusu açılacaktır:

sayma boş daha az 9

30 günlük ücretsiz deneme için Kutools for Excel'i indirmek için tıklayın.


Belirli bir değerden küçük, büyük veya ona eşit hücreler için EĞERSAY işlevi

Burada, Excel'deki belirli bir değerden küçük, büyük, ona eşit veya eşit olmayan değerlere sahip hücreleri saymak için iki ana yöntemi listeledik.

EĞERSAY formüllerle küçüktür, büyüktür, eşittir veya eşit değildir

Belirli bir değerden küçük, büyük, ona eşit veya belirli bir değere eşit olmayan değerlere sahip hücreleri saymak için bir formül kullanmak için, iyi bir şekilde kullanmalısınız. Karşılaştırma Operatörleri (<, >, =, ).

Not: Yöntem, belirttiğiniz tarihten önce (<'den küçük), sonra (>'den büyük) veya buna eşit (=) olan tarihleri ​​olan hücreleri saymak için de kullanılabilir.

Şimdi, aşağıdaki tabloya göre bazı gerçek örneklere bakalım:

sayma boş daha az 10

Toplam puanı olan öğrenci sayısını saymak için üzerinde (>) 140, formülü kullanın:
=EĞERSAY(E2:E8;">140") >>> Sonuç 5
Matematik puanı olan öğrenci sayısını saymak için daha düşük (<) Coco puanı (D3 hücresindeki değer), formülü kullanın:
=EĞERSAY(D2:D8;"<"&D3) >>> Sonuç 2
Not: EĞERSAY işlevinde karşılaştırma işleçleriyle bir hücre başvurusu kullanmak için, işleçleri tırnak içine almanız ve hücre başvurusunun önüne bir ve işareti (&) eklemeniz gerekir.
İngilizce puanı olan öğrenci sayısını saymak için (≥) üzerinde veya eşittir Eddie'nin puanı (C4 hücresindeki değer), aşağıdaki formülü kullanın:
=COUNTIF(C2:C8,">="&C4)-1 >>> The result is 5
Not: 1'i çıkarmanın nedeni, kriterlerin C2:C8,">="&C4 EĞERSAY'dan Eddie'nin İngilizce puanı da dahil tüm eşleşen hücreleri saymasını isteyin, bu yüzden onu formülden çıkarmamız gerekir. Eddie'yi dahil etmeniz gerekiyorsa, "-1” formülünden.
Öğrenci sayısını saymak için (=) Hindistan, formülü kullanın:
=EĞERSAY(B2:B8;"Hindistan") OR =EĞERSAY(B2:B8;B2) >>> Sonuç 3
Not: B2 hücre başvurusundaki değer Hindistan'dır, bu nedenle "Hindistan" ve B2 ikisi de burada kriter olarak çalışıyor. EĞERSAY işlevinde, ölçütler şunlardır: büyük küçük harf duyarlı değil. Dolayısıyla, "Hindistan" ve "HİNDİSTAN" dizeleri, formülün sonucu için hiçbir fark yaratmayacaktır.
Öğrenci sayısını saymak için (≠) Hindistan'dan değil, formülü kullanın:
=EĞERSAY(B2:B8;"<>Hindistan") OR =EĞERSAY(B2:B8;"<>"&B2) >>> Sonuç 4

EĞERSAY işlevi yalnızca bir koşul olduğunda çalışır, daha fazla koşulun durumu için EĞERSAY işlevini kullanmanız gerekir. Örneğin, İngilizce puanı 60 ile 90 (>60, <90) arasında olan öğrencilerin sayısını saymak için aşağıdaki formülü kullanın: =COUNTIFS(B2:B8,">60",B2:B8,"<90").
EĞERSAY işlevi hakkında daha fazla bilgi için tıklayın…


EĞERSAY daha az, daha büyük, eşit veya eşit değil birkaç tıklama ile

Belirli bir değerden küçük, büyük, eşit veya eşit olmayan değerlere sahip hücreleri daha uygun bir şekilde saymak için aşağıdakileri uygulayabilirsiniz: Belirli Hücreleri Seçin özellikf Kutools for Excel.

Kutools for Excel'i yükledikten sonra lütfen aşağıdaki adımları uygulayın:

1. Lütfen bulun Kutools sekmesine gidin, ardından seçmekVe tıklama Belirli Hücreleri Seçin açılır listede.

sayma boş daha az 11

2. Şimdi bir açılır pencere göreceksiniz, lütfen aşağıdakileri yapın:

sayma boş daha az 11

Aşağıda matematik puanı olan öğrenci sayısını saymak için bir örnek verilmiştir. daha düşük (<) Kutools ile Coco'nun puanı.

sayma boş daha az 11

Not: Program, sayım sonucunu döndürecek ve kriterlerinize uyan hücreyi/hücreleri seçecektir. Gerekirse onları kopyalayabilirsiniz.

30 günlük ücretsiz deneme için Kutools for Excel'i indirmek için tıklayın.


Hücreler için EĞERSAY işlevi belirli bir değer içeriyor

Belirli bir değer içeren hücreleri saymak için (örneğin Y harfi olan hücreleri) veya hatta belirli bir konumdaki belirli bir değeri olan hücreleri saymak için EĞERSAY kullanmak için (örneğin hücreler Y harfi ile başlar), biz joker karakterler hakkında bilgi sahibi olmanız gerekir.

Üç joker karakter vardır - yıldız işareti (*), soru işaret (?), Ve tilde (~) EĞERSAY işlevi için Excel'de bulunur:

yıldız işareti (*) - Herhangi bir sayıda karakterle eşleşir. Örneğin *buz, güzel, hizmet, buz, @#$buz vb. anlamına gelebilir.
Soru işareti (?) - Herhangi bir karakterle eşleşir. Örneğin, m?? daha fazla, ay, ay&%, moaa, vb. anlamına gelebilir.
tilde (~) - Gerçek joker karakterle eşleşir. Örneğin, ~* harfi harfine yıldız işareti anlamına gelir, ~~ harfi harfine yaklaşık işareti anlamına gelir.

Not: Boole değerleri (DOĞRU ve YANLIŞ), sayılar, tarihler ve hatalar karakter olarak sayılmaz. Bu nedenle, seçtiğiniz hücre aralığında yukarıdaki öğeler varsa, bunları metne dönüştürmeniz gerekecektir.

Daha fazla bilgi:
Excel'de Sayıyı Metne Nasıl Değiştirir veya Çevirirsiniz?
Excel'de Tarih Sayı Dizisine veya Metin Biçimine Nasıl Dönüştürülür?
Excel'de # Formül Hatalarını 0, Boş veya Belirli Metinlerle Nasıl Değiştirebilirim?
Excel'de Boole Doğru/Yanlış Sayı (1/0) veya Metne Nasıl Dönüştürülür?


EĞERSAY işleviyle belirli kelime(ler) veya karakter(ler) içeren hücreleri sayın

Joker karakterleri zaten bildiğimize göre, belirli bir karakter(ler) veya kelime(ler) içeren hücreleri saymak için bir EĞERSAY formülünü nasıl kullanacağımızı öğrenmemizin zamanı geldi. Aşağıdaki örnekleri görelim:

sayma boş daha az 1

Sınıftaki erkekleri saymak için aşağıdaki formülü kullanın:
=EĞERSAY(B2:B9;"ERKEK") >>> Sonuç 5
"jeff" karakterlerini (A6 hücresindeki değer) içeren adların sayısını saymak için şu formülü kullanın:
=EĞERSAY(A2:A9,"*jeff*") OR = EĞERSAY (A2: A9; "*" & A6 & "*") >>> Sonuç 2
“e” harfini içeren isimlerin sayısını saymak için aşağıdaki formülü kullanın:
=COUNTIF(A2:A9,"*e*") >>> The result is 5
“e” harfini içermeyen isimleri saymak için aşağıdaki formülü kullanın:
=EĞERSAY(A2:A9,"<>*e*") >>> Sonuç 3
“e” harfiyle başlayan isimleri saymak için aşağıdaki formülü kullanın:
=EĞERSAY(A2:A9;"e*") >>> Sonuç 2
"e" harfiyle biten isimleri saymak için aşağıdaki formülü kullanın:
=EĞERSAY(A2:A9;"*e") >>> Sonuç 1
Üçüncü karakter olarak “m” harfine sahip isimleri saymak için aşağıdaki formülü kullanın:
=EĞERSAY(A2:A9,"??m*") >>> Sonuç 2

Birkaç tıklama ile belirli kelime(ler) veya karakter(ler) içeren hücreleri sayın

O ileur Excel eklentisi installed, lütfen aşağıdaki gibi yapın:

1. Git Kutools sekme, bul seçmekVe tıklama Belirli Hücreleri Seçin açılır listede.

sayma boş daha az 1

2. içinde Belirli Hücreleri Seçin iletişim kutusunda, saymak istediğiniz hücre aralığını seçin ve ardından Hücre altında Seçim türü, açılır listeden bir koşul seçin. Belirli tür İhtiyaçlarınıza göre.

sayma boş daha az 1

Burada size iki örnek vereceğim kullanmanın Kutools düşünmekt Belirli kelime(ler)i veya karakter(ler)i içeren hücreler.

• Sınıftaki erkek öğrencilerin sayısını saymak için tıklayın. eşittir açılır listeye yazın ve Erkek sağdaki giriş kutusunda veya çalışma sayfasında "Erkek" değerine sahip bir hücreyi tıklayarak seçebilirsiniz. sayma boş daha az 1düğmesine basın.

sayma boş daha az 1

Program, sayım sonucunu döndürecek ve kriterlerinize uyan hücreyi/hücreleri seçecektir. Gerekirse onları kopyalayabilirsiniz.

• “jeff” karakterlerini içeren adların sayısını saymak için İçeren açılır listeye yazın ve jeffveya tıklayarak çalışma sayfasındaki A6 hücresini seçebilirsiniz. sayma boş daha az 1düğmesine basın.

sayma boş daha az 1

Program, sayım sonucunu döndürecek ve kriterlerinize uyan hücreyi/hücreleri seçecektir. Gerekirse onları kopyalayabilirsiniz.



  • Süper Formül Çubuğu (birden çok metin ve formül satırını kolayca düzenleyin); Okuma Düzeni (çok sayıda hücreyi kolayca okuyun ve düzenleyin); Filtrelenmiş Aralığa Yapıştır...
  • Hücreleri / Satırları / Sütunları Birleştirme ve Verilerin Saklanması; Bölünmüş Hücre İçeriği; Yinelenen Satırları ve Toplam / Ortalamayı Birleştirme... Yinelenen Hücreleri Önleyin; Aralıkları Karşılaştır...
  • Yinelenen veya Benzersiz'i seçin Satırlar; Boş Satırları Seçin (tüm hücreler boştur); Süper Bul ve Bulanık Bul Birçok Çalışma Kitabında; Rastgele Seçim ...
  • Tam kopya Formül referansını değiştirmeden Birden Çok Hücre; Otomatik Referans Oluştur Birden Çok Sayfaya; Madde İşaretleri Ekle, Onay Kutuları ve daha fazlası ...
  • Sık Kullanılan ve Hızlı Eklenen Formüller, Aralıklar, Grafikler ve Resimler; Hücreleri Şifrele şifre ile; Posta Listesi Oluşturun ve e-posta gönder ...
  • Metni Çıkar, Metin Ekle, Konuma Göre Kaldır, Alanı Kaldır; Sayfalama Alt Toplamları Oluşturma ve Yazdırma; Hücre İçeriği ve Yorumları Arasında Dönüştür...
  • Süper Filtre (filtre şemalarını kaydedin ve diğer sayfalara uygulayın); Gelişmiş Sıralama ay / hafta / gün, sıklık ve daha fazlasına göre; Özel Filtre kalın, italik ...
  • Çalışma Kitaplarını ve Çalışma Sayfalarını Birleştirin; Tabloları anahtar sütunlara göre birleştirin; Verileri Birden Çok Sayfaya Bölme; Toplu dönüştürme xls, xlsx ve PDF...
  • Pivot Tablo Gruplaması hafta numarası, haftanın günü ve daha fazlası ... Kilidi Açılmış, Kilitli Hücreleri Göster farklı renklerle; Formülü / Adı Olan Hücreleri Vurgulayın...
kte sekmesi 201905
  • Word, Excel, PowerPoint'te sekmeli düzenlemeyi ve okumayı etkinleştirin, Publisher, Access, Visio ve Project.
  • Yeni pencereler yerine aynı pencerenin yeni sekmelerinde birden çok belge açın ve oluşturun.
  • Üretkenliğinizi% 50 artırır ve her gün sizin için yüzlerce fare tıklamasını azaltır!
ofis tabanı
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.

Be the first to comment.