Note: The other languages of the website are Google-translated. Back to English
English English

Excel'de metin içeren hücreler nasıl sayılır

Excel her yerdedir. Veri analizi ve dokümantasyonu için yararlı ve güçlü bir araç olarak, genellikle iş ve yaşamda kullanırız. Bazı durumlarda, veri analizi yapmak için verilerimizi daha iyi anlamamız gerekebilir. Bu eğitimde, birden çok yol göstereceğiz metin içeren hücreleri say Excel'de.

EĞERSAY/EĞERSAY işlevi + Excel'de metin içeren hücreleri saymak için joker karakter

Excel'de metin içeren hücreleri saymak için SUMPRODUCT + ISTEXT işlevleri

Excel'de belirli metni içeren hücreleri saymak için EĞERSAY işlevi

Kutools for Excel ile belirli metni içeren hücreleri kolayca sayın


EĞERSAY/EĞERSAY işlevi + Excel'de metin içeren hücreleri saymak için joker karakter

Herhangi bir metin içeren hücreleri saymak için EĞERSAY işlevi

Herhangi bir metin içeren hücreleri saymak için yıldız işareti (*) EĞERSAY formülünde. bu sözdizimi arasında EĞERSAY işlevi aşağıdaki gibidir:

=COUNTIF(range, "*")

Yıldız işareti (*) herhangi bir karakter dizisiyle eşleşen bir joker karakter olduğundan, formül herhangi bir metin içeren tüm hücreleri sayar.

Örneğin, saymak metin içeren hücreler aşağıda gösterildiği gibi A2:A15 aralığında, aşağıdaki formülü boş bir hücreye yazın ve Keşfet sonuç almak için düğmesine basın.

=EĞERSAY(A2:A15; "*")

metinli hücreyi say 1

√ Notlar:
  • Metin olarak sayılmayanlar:
  1. Herhangi bir metin içeren hücreler;
  2. Özel karakterler;
  3. Metin olarak biçimlendirilmiş sayılar;
  4. Boş bir dize (=""), kesme işareti ('), boşluk içeren görsel olarak boş hücreler.
  • Metin olarak sayılmayanlar:
  1. Sayılar;
  2. Tarih;
  3. True ve False'ın mantıksal değerleri;
  4. Hatalar;
  5. Boş hücreler.

Bu durumda, neden olduğunu açıkça anlayabiliriz. 8 örnek çalışma sayfasında metin içeren hücreler.

metinli hücreyi say 2

EĞERSAY işlevi metin içermeyen hücreleri sayar

Bir veri aralığında metin içermeyen hücreleri saymak için mantıksal operatöre eşit değil (<>) ve yıldız işareti (*) EĞERSAY formülünde. Sözdizimi aşağıdaki gibidir:

=COUNTIF(range, "<>*")

Mantıksal operatöre eşit değil (<>) ve yıldız işareti (*) hiçbir karaktere eşit olmadığı anlamına geldiğinden, formül hücreleri metin olmadan sayar.

Örneğin, metin içermeyen hücreleri say A2:A15 aralığında, aşağıdaki formülü boş bir hücreye yazın ve Keşfet sonuç almak için düğmesine basın.

=EĞERSAY(A2:A15;"<>*")

metinli hücreyi say 3

Ardından, metin olmayan değerler içeren hücre sayısını alırsınız.

EĞERSAY işlevi, görsel olarak boş hücreler hariç metin içeren hücreleri sayar

Görsel olarak boş hücreleri hariç tutan metin içeren hücreleri saymak için, formülde yıldız işareti (*), soru işareti (?) ve eşit değil (<>) mantıksal operatörünü kullanın. Sözdizimi aşağıdaki gibidir:

=COUNTIFS(range,"*?*", range, "<> ")

A soru işareti simgesi (?) maçlar herhangi bir tek karakter, ve yıldız işareti (*) maçlar herhangi bir karakter dizisi. bir yıldızla çevrili soru işareti (*?*) anlamına gelir hücrede en az bir karakter olmalıdır, bu nedenle boş dize ve kesme işareti sayılmaz.

The eşit değil sembolü (<>) artı bir boş alan anlamına geliyor boşluk karakteri olan hücreleri saymamak.

Örneğin, A2:A15 aralığında görsel olarak boş hücreleri olmayan metin içeren hücreleri saymak için aşağıdaki formülü boş bir hücreye yazın ve Keşfet sonuç almak için düğmesine basın.

=EĞERSAY(A2:A15,"*?*", A2:A15, "<> ")

metinli hücreyi say 4

Sonra hücre sayısını alabilirsiniz yalnızca görünür metin içerir.

√ Notlar:
  1. EĞERSAY işlevi birden çok koşulu destekler. Yukarıdaki örnekte, metin içeren hücreleri saymak ve ayrıca tümü hücrelerin boş görünmesini sağlayan yalnızca bir boşluk, boş dize ve kesme işareti içeren hücreleri hariç tutmak için.
  2. Metin içeren hücreleri saymak ve yalnızca bir boşluk içeren hücreleri saymak istemiyorsanız, sözdizimi şöyle olur: = EĞERSAY(aralık,"*", aralık, "<> ").

Excel'de metin içeren hücreleri saymak için SUMPRODUCT + ISTEXT işlevleri

Metin değerlerine sahip hücreleri saymanın ikinci yolu, SUMPRODUCT işlevi ile birlikte ISTEXT işlevi. sözdizimi aşağıdaki gibidir:

=SUMPRODUCT(--ISTEXT(range))
or
=SUMPRODUCT(ISTEXT(range)*1)

The ISTEXT işlevi İade Doğru ya da yanlış bir hücre metin içerdiğinde veya metin dışı olduğunda. Ve çift ​​negatif (--) ilk sözdiziminde ve çarpma işlemi ikinci sözdiziminde iki yol vardır DOĞRU ve YANLIŞ'ı sayısal 1 ve 0'a zorla.

Sonra SUMPRODUCT işlevi İade tüm birler ve sıfırların toplamı arama aralığında ve son bir sayı verir.

Bu durumda, A2:A15 aralığında metin içeren hücreleri saymak için aşağıdaki formülü boş bir hücreye yazın ve Keşfet sonuç almak için düğmesine basın.

=TOPLAÇA(--ISTEXT(A2:A15))

or

=TOPLAÇARI(ISTEXT(A2:A15)*1)

metinli hücreyi say 5

metinli hücreyi say 6

Hangi sözdizimini kullanırsanız kullanın, döndürülen sonuç 8.

Excel'de belirli metni içeren hücreleri saymak için EĞERSAY işlevi

Tam eşleşme ile belirli metni içeren hücreleri sayın

Gerçekleştirmek için tam eşleşme EĞERSAY işlevinin tam metnini formüldeki ikinci bağımsız değişkene tırnak işaretleri içinde girmeniz yeterlidir. İşte sözdizimi:

=COUNTIF(range, "text value")

Excel'de bir formüle metin eklemek için, metni tırnak içine alma ("…") gerekli.

Örneğin, A2:A10 aralığında tam olarak "kalem" veya "kalem" kelimesini içeren hücre sayısını bulmak istiyorsanız, aşağıdaki formülü boş bir hücreye yazın ve Keşfet sonuç almak için düğmesine basın.

=EĞERSAY(A2:A10, "kalem")

or

=EĞERSAY(A2:A10, "kalem")

metinli hücreyi say 7

metinli hücreyi say 8

Kısmi eşleşmeyle belirli metni içeren hücreleri sayın

ile hücreleri saymak için kısmi eşleşme, metni iki yıldız işareti (*) arasına yerleştirin ve tırnak işaretleri (“”) içine alın. Sonra COUNTIF'e izin verir metni içeren tüm hücreleri ve ondan önceki ve sonraki her şeyi sayın. Burada bir sözdizimi:

=COUNTIF(range, "*text value*")

Bu durumda, herhangi bir konumda içeriğinin bir parçası olarak kaç hücrenin “kalem” veya “kalem” içerdiğini saymak istediğinizi varsayalım, aşağıdaki formülü boş bir hücreye yazın ve Keşfet sonuç almak için düğmesine basın.

=EĞERSAY(A2:A10, "*kalem*")

or

=EĞERSAY(A2:A10, "*kalem*")

metinli hücreyi say 9

metinli hücreyi say 10

√ Notlar: EĞERSAY büyük/küçük harfe duyarlı değildir.

Kutools for Excel ile belirli metni içeren hücreleri kolayca sayın

Metin içeren hücreleri saymak için bir formül kullanmanın yanı sıra, Belirli Hücreleri Seçin yarar Kutools for Excel Excel'de belirli metin içeren hücreleri hızla saymak ve seçmek için.

Belirli bir metni içeren hücreleri saymak istediğinizde tam eşleşme veya bir kısmi eşleşme, Kutools for Excel, hedefinize kolayca ulaşmanıza yardımcı olabilir.

Kutools for Excel : 300'den fazla kullanışlı Excel eklentisi ile 30 günde sınırlama olmaksızın ücretsiz deneyin.

Sonra ücretsiz kurulum Kutools for Excel, nasıl çalıştığına bir göz atalım!

Kutools ile belirli metinlerle tam olarak eşleşen hücreleri sayın ve seçin

Bu durumda, A2:A10 aralığındaki kaç hücrenin tam olarak “kalem” metnini içerdiğini bulmak istersiniz.

metinli hücreyi say 11

1. Belirli metni içeren hücreleri saymak istediğiniz aralığı seçin.

2. tık Kutools > seçmek > Belirli Hücreleri Seçin.

metinli hücreyi say 12

3. içinde Belirli Hücreleri Seç iletişim kutusu, gerek:

  • seçmek Hücre seçeneği içinde Seçim türü bölümü;
  • Belirli tür bölümünde, eşittir açılır listeye şunu girin: kalem metin kutusunda;
  • Tıkla OK buton. Sonra bir bilgi istemi kutusu kaç hücrenin koşulla eşleştiğini söylemek için açılır.

metinli hücreyi say 13

  • Tıkla OK bilgi istemi kutusundaki düğme ve tüm nitelikli hücreler aynı anda Excel'de seçilir.

metinli hücreyi say 14

Kutools ile belirli metinlerle kısmen eşleşen hücreleri sayın ve seçin

A2:A10 aralığındaki kaç hücrenin herhangi bir konumda içeriğin bir parçası olarak "kalem" kelimesini içerdiğini saymak istediğinizi varsayalım. Hile sonuncusuna benzer.

1. Belirli metni içeren hücre sayısını saymak istediğiniz aralığı seçin.

2. tık Kutools > seçmek > Belirli Hücreleri Seçin.

metinli hücreyi say 12

3. içinde Belirli Hücreleri Seç iletişim kutusu, gerek:

  • seçmek Hücre seçeneği içinde Seçim türü bölümü;
  • Belirli tür bölümünde, İçeren açılır listede, kalem girin metin kutusunda;
  • Tıkla OK buton. Sonra bir bilgi istemi kutusu kaç hücrenin koşulla eşleştiğini söylemek için açılır.

metinli hücreyi say 15

  • Tıkla OK bilgi istemi kutusundaki düğme ve tüm nitelikli hücreler aynı anda Excel'de seçilir.

metinli hücreyi say 16

30 günlük ücretsiz deneme için Kutools for Excel'i indirmek için tıklayın.



  • Süper Formül Çubuğu (birden çok metin ve formül satırını kolayca düzenleyin); Okuma Düzeni (çok sayıda hücreyi kolayca okuyun ve düzenleyin); Filtrelenmiş Aralığa Yapıştır...
  • Hücreleri / Satırları / Sütunları Birleştirme ve Verilerin Saklanması; Bölünmüş Hücre İçeriği; Yinelenen Satırları ve Toplam / Ortalamayı Birleştirme... Yinelenen Hücreleri Önleyin; Aralıkları Karşılaştır...
  • Yinelenen veya Benzersiz'i seçin Satırlar; Boş Satırları Seçin (tüm hücreler boştur); Süper Bul ve Bulanık Bul Birçok Çalışma Kitabında; Rastgele Seçim ...
  • Tam kopya Formül referansını değiştirmeden Birden Çok Hücre; Otomatik Referans Oluştur Birden Çok Sayfaya; Madde İşaretleri Ekle, Onay Kutuları ve daha fazlası ...
  • Sık Kullanılan ve Hızlı Eklenen Formüller, Aralıklar, Grafikler ve Resimler; Hücreleri Şifrele şifre ile; Posta Listesi Oluşturun ve e-posta gönder ...
  • Metni Çıkar, Metin Ekle, Konuma Göre Kaldır, Alanı Kaldır; Sayfalama Alt Toplamları Oluşturma ve Yazdırma; Hücre İçeriği ve Yorumları Arasında Dönüştür...
  • Süper Filtre (filtre şemalarını kaydedin ve diğer sayfalara uygulayın); Gelişmiş Sıralama ay / hafta / gün, sıklık ve daha fazlasına göre; Özel Filtre kalın, italik ...
  • Çalışma Kitaplarını ve Çalışma Sayfalarını Birleştirin; Tabloları anahtar sütunlara göre birleştirin; Verileri Birden Çok Sayfaya Bölme; Toplu dönüştürme xls, xlsx ve PDF...
  • Pivot Tablo Gruplaması hafta numarası, haftanın günü ve daha fazlası ... Kilidi Açılmış, Kilitli Hücreleri Göster farklı renklerle; Formülü / Adı Olan Hücreleri Vurgulayın...
kte sekmesi 201905
  • Word, Excel, PowerPoint'te sekmeli düzenlemeyi ve okumayı etkinleştirin, Publisher, Access, Visio ve Project.
  • Yeni pencereler yerine aynı pencerenin yeni sekmelerinde birden çok belge açın ve oluşturun.
  • Üretkenliğinizi% 50 artırır ve her gün sizin için yüzlerce fare tıklamasını azaltır!
ofis tabanı
Yorumları sıralama ölçütü
Yorumlar (0)
Henüz derecelendirme yok. İlk değerlendiren siz olun!
Buraya henüz hiç yorum yapılmamış
Lütfen yorum yazın
Misafir olarak yayınlama
×
Bu gönderiyi değerlendirin:
0   Karakterler
Önerilen Konumlar