Note: The other languages of the website are Google-translated. Back to English

Belirli sayıda karakter içeren hücre sayısını sayın

Aşağıdaki ekran görüntüsü gibi bir hücre aralığında belirli sayıda karakter (5 karakter gibi) içeren hücre sayısını saymak istiyorsanız. Excel'de EĞERSAY işlevi size bir iyilik yapabilir. Bu yazıda, tam olarak x karakter içeren hücre sayısını veya belirli sayıda karakterden daha fazlasını içeren hücrelerin nasıl elde edileceğinden bahsedeceğim.


Tam olarak x karakter içeren hücre sayısını sayın

EĞERSAY işlevi, belirli sayıda karakter içeren hücre sayısını elde etmenize yardımcı olabilir, genel sözdizimi şöyledir:

=COUNTIF(range,"?????")
=EĞERSAY(aralık,REPT(“?”,X))
  • range: Saymak istediğiniz hücre aralığı;
  • ?: Herhangi bir tek karakterle eşleşen bir joker karakteri belirtir;
  • X: Sayılacak karakter sayısı esas alınır.

1. Sonucu çıkarmak için lütfen aşağıdaki formüllerden herhangi birini boş bir hücreye girin veya kopyalayın:

=COUNTIF(A2:A12,"?????")
=EĞERSAY(A2:A13,REPT("?",5))

not: Birinci formülde, ????? dayalı olarak saymak istediğiniz beş karakteri belirtir; İkinci formülde, TEKRAR(“?”,5) tam olarak 5 soru işaretinden oluşan bir metin dizisi döndürür. Bu örnekte REPT("?",5) "?????" değerini döndürür.

2. Ve sonra Keşfet ihtiyacınız olan sonucu almak için anahtar, ekran görüntüsüne bakın:


Metin uzunluğu x karakterden büyük olan hücre sayısını sayın

Metin uzunluğunun 15 karakterden büyük olduğu hücre sayısını elde etmek istiyorsanız, SUMPRODUCT, UZUNLUK ve N işlevlerini birlikte uygulayabilirsiniz, genel sözdizimi şöyledir:

=TOPLAÇA(N(UZUNLUK(aralık)>X))
  • range: Saymak istediğiniz hücre aralığı;
  • X: Sayılacak karakter sayısı esas alınır.

1. Lütfen aşağıdaki formülü boş bir hücreye girin veya kopyalayın:

=SUMPRODUCT(N(LEN(A2:A10)>15))

2. Ardından sonucu bir kerede almak için Enter tuşuna basın, ekran görüntüsüne bakın:


Formülün açıklaması:
  • UZUNLUK(A2:A10): Bu LEN işlevi, seçilen aralığın her hücresinin uzunluğunu hesaplar ve dizi listesini şu şekilde döndürür: {17;10;12;22;19;10;14;21;9}.
  • UZUNLUK(A2:A10)>15: Bu kısım, her hücrenin metin uzunluğunu belirli sayı 15 ile karşılaştırır, 15'ten büyükse DOĞRU gösterir, aksi takdirde YANLIŞ döndürür. Sonucu şu şekilde alacaktır: {TRUE;FALSE;FALSE;TRUE;TRUE;FALSE;FALSE;TRUE;FALSE}.
  • N(UZUNLUK(A2:A10)>15): Bu N işlevi DOĞRU ve YANLIŞ'ı sırasıyla 1 ve 0'a dönüştürmek için kullanılır, şöyle: {1;0;0;1;1;0;0;1;0}
  • SUMPRODUCT(N(LEN(A2:A10)>15))=SUMPRODUCT({1;0;0;1;1;0;0;1;0}): Sonunda, bu SUMPRODUCT işlevi dizideki tüm sayıları toplayacak, böylece sonucu alacaksınız: 4.

Kullanılan göreceli işlev:

  • COUNTIF:
  • EĞERSAY işlevi, Excel'de bir ölçütü karşılayan hücrelerin sayısını saymak için kullanılan istatistiksel bir işlevdir.
  • SUMPRODUCT:
  • SUMPRODUCT işlevi, iki veya daha fazla sütunu veya diziyi birlikte çarpmak ve ardından ürünlerin toplamını elde etmek için kullanılabilir.
  • LEN:
  • UZUNLUK işlevi, bir metin dizesindeki karakter sayısını döndürür.
  • N:
  • N işlevi, bir değeri sayıya dönüştürür.

Daha fazla makale:

  • Excel'de birçok değere eşit olmayan hücre sayısını sayın
  • Excel'de, EĞERSAY işlevini kullanarak belirli bir değere eşit olmayan hücre sayısını kolayca alabilirsiniz, ancak hiç çok sayıda değere eşit olmayan hücreleri saymayı denediniz mi? Örneğin, A sütunundaki ürünlerin toplam sayısını almak istiyorum, ancak aşağıda gösterilen ekran görüntüsü gibi C4:C6'daki belirli öğeleri hariç tutmak istiyorum. Bu yazıda, Excel'de bu işi çözmek için bazı formüller tanıtacağım.
  • Sayısal veya Sayısal Olmayan Değerler İçeren Hücre Sayısı
  • Hem sayısal hem de sayısal olmayan değerler içeren bir veri aralığınız varsa ve şimdi, aşağıda gösterilen ekran görüntüsü gibi sayısal veya sayısal olmayan hücrelerin sayısını saymak isteyebilirsiniz. Bu yazıda, Excel'de bu görevi çözmek için bazı formüllerden bahsedeceğim.

En İyi Ofis Üretkenliği Araçları

Kutools for Excel - Kalabalıktan Ayrılmanıza Yardımcı Olur

Günlük işlerinizi hızlı ve kusursuz bir şekilde tamamlamak ister misiniz? Kutools for Excel, 300 güçlü gelişmiş özellik getiriyor (Çalışma kitaplarını birleştir, renge göre topla, hücre içeriğini böl, tarihi dönüştür, vb.) ve senin için% 80 zamandan tasarruf et.

  • 1500 çalışma senaryosu için tasarlanmış olup, Excel problemlerinin %80'ini çözmenize yardımcı olur.
  • Her gün binlerce klavye ve fare tıklamasını azaltın, yorgun gözlerinizi ve ellerinizi rahatlatın.
  • 3 dakikada bir Excel uzmanı olun. Artık acı veren formülleri ve VBA kodlarını hatırlamanıza gerek yok.
  • 30 günlük sınırsız ücretsiz deneme. 60 günlük para iade garantisi. 2 yıl boyunca ücretsiz yükseltme ve destek.
Excel şeridi (Kutools for Excel yüklü)

Office Sekmesi - Microsoft Office'te Sekmeli Okuma ve Düzenlemeyi Etkinleştir (Excel dahil)

  • Düzinelerce açık belge arasında geçiş yapmak için bir saniye!
  • Her gün yüzlerce fare tıklamasını azaltın, fare eline veda edin.
  • Birden çok belgeyi görüntülerken ve düzenlerken üretkenliğinizi% 50 artırır.
  • Office'e (Excel dahil), Chrome, Firefox ve Yeni Internet Explorer gibi Verimli Sekmeler Getirir.
Excel'in Ekran Görüntüsü (Office Tab yüklü)
Yorumları sıralama ölçütü
Yorumlar (0)
Henüz derecelendirme yok. İlk değerlendiren siz olun!
Buraya henüz hiç yorum yapılmamış
Lütfen yorum yazın
Misafir olarak yayınlama
×
Bu gönderiyi değerlendirin:
0   Karakterler
Önerilen Konumlar

Bizi takip et

Telif Hakkı © 2009 - www.extendoffice.com. | Tüm hakları Saklıdır. Tarafından desteklenmektedir ExtendOffice. | | | Site Haritası
Microsoft ve Office logosu, Microsoft Corporation'ın Amerika Birleşik Devletleri ve / veya diğer ülkelerdeki ticari markaları veya tescilli ticari markalarıdır.
Sectigo SSL ile korunmaktadır