Note: The other languages of the website are Google-translated. Back to English

Eksik değerleri bul

Excel'deki B listesinde A listesinin bir değerinin olup olmadığını kontrol etmek için iki listeyi karşılaştırmanız gereken durumlar vardır. Örneğin, bir ürün listeniz var ve listenizdeki ürünlerin tedarikçiniz tarafından sağlanan ürün listesinde olup olmadığını kontrol etmek istiyorsunuz. Bu görevi gerçekleştirmek için aşağıda üç yol listeledik, beğendiğinizi seçmekten çekinmeyin.

eksik değerleri bul 1

MATCH, ISNA ve IF ile eksik değerleri bulun
DÜŞEYARA, ISNA ve IF ile eksik değerleri bulun
EĞERSAY ve EĞER ile eksik değerleri bulun


MATCH, ISNA ve IF ile eksik değerleri bulun

Bulmak için listenizdeki tüm ürünler tedarikçi listenizde mevcutsa Yukarıdaki ekran görüntüsünde gösterildiği gibi, listenizdeki bir ürünün (A listesinin değeri) tedarikçi listesindeki (B listesi) konumunu almak için önce KAÇINCI işlevini kullanabilirsiniz. MATCH, bir ürün bulunamadığında #N/A hatasını döndürür. Ardından, #N/A hatalarını TRUE'lara, yani bu ürünlerin eksik olduğuna dönüştürmek için sonucu ISNA'ya besleyebilirsiniz. EĞER işlevi daha sonra beklediğiniz sonucu döndürür.

Genel sözdizimi

=IF(ISNA(MATCH("lookup_value",lookup_range,0)),"Missing","Found")

√ Not: "Eksik", "Bulundu" değerlerini istediğiniz gibi değiştirebilirsiniz.

  • aranan_değer: MATCH değeri, içinde varsa konumunu almak için kullanılır. aranan_aralık veya değilse #YOK hatası. Burada listenizdeki ürünleri ifade eder.
  • arama_aralığı: Karşılaştırılacak hücre aralığı lookup_value. Burada tedarikçinin ürün listesine atıfta bulunulmaktadır.

Bulmak için listenizdeki tüm ürünler tedarikçi listenizde mevcutsa, lütfen aşağıdaki formülü kopyalayın veya H6 hücresine girin ve Keşfet sonucu almak için:

=EĞER(ESNA(KAÇINMA(30002,6 $ B $: 10 B $,0)),"Eksik","Bulundu")

Veya formülü dinamik hale getirmek için bir hücre başvurusu kullanın:

=EĞER(ESNA(KAÇINMA(G6,6 $ B $: 10 B $,0)),"Eksik","Bulundu")

√ Not: Yukarıdaki dolar işaretleri ($) mutlak referansları gösterir, yani aranan_aralık formülü diğer hücrelere taşıdığınızda veya kopyaladığınızda değişmez. Ancak, eklenmiş herhangi bir dolar işareti yoktur. lookup_value dinamik olmasını istediğiniz için. Formülü girdikten sonra, formülü aşağıdaki hücrelere uygulamak için doldurma tutamacını aşağı sürükleyin.

eksik değerleri bul 2

Formülün açıklaması

Burada örnek olarak aşağıdaki formülü kullanıyoruz:

=IF(ISNA(MATCH(G8,$B$6:$B$10,0)),"Missing","Found")

  • MAÇ(G8,$B$6:$B$10,0): Match_type 0 KAÇINCI işlevini, ilk eşleşmenin konumunu gösteren sayısal bir değer döndürmeye zorlar. 3004, dizideki G8 hücresindeki değer 6 $ B $: 10 B $. Ancak, bu durumda MATCH, arama dizisindeki değeri bulamadı, bu nedenle # N / A hata.
  • İSNA(MAÇ(G8,$B$6:$B$10,0)) = İSNA(# N / A): ISNA, bir değerin “#N/A” hatası olup olmadığını bulmaya çalışır. Evet ise, işlev TURE döndürür; Değer "#N/A" hatasından başka bir şey değilse, YANLIŞ döndürür. Yani, bu ISNA formülü geri dönecek ZELLİKLER.
  • EĞER(İSNA(MAÇ(G8,$B$6:$B$10,0)),"Eksik","Bulundu") = EĞER(DOĞRU,"Eksik","Bulundu"): ISNA ve MATCH tarafından yapılan karşılaştırma DOĞRU ise EĞER işlevi Eksik, aksi takdirde Bulundu değerini döndürür. Yani formül dönecek Eksik.

DÜŞEYARA, ISNA ve IF ile eksik değerleri bulun

Listenizdeki tüm ürünlerin tedarikçinizin listesinde olup olmadığını öğrenmek için, yukarıdaki KAÇINCI işlevini DÜŞEYARA ile değiştirebilirsiniz, çünkü KAÇINCI ile aynı şekilde çalışır, değer listede yoksa #YOK hatası verir. başka bir liste, yoksa eksik deriz.

Genel sözdizimi

=IF(ISNA(VLOOKUP("lookup_value",lookup_range,1,FALSE)),"Missing","Found")

√ Not: "Eksik", "Bulundu" değerlerini istediğiniz gibi değiştirebilirsiniz.

  • aranan_değer: DÜŞEYARA değeri, içinde varsa konumunu almak için kullanılır. aranan_aralık veya değilse #YOK hatası. Burada listenizdeki ürünleri ifade eder.
  • arama_aralığı: Karşılaştırılacak hücre aralığı lookup_value. Burada tedarikçinin ürün listesine atıfta bulunulmaktadır.

Listenizdeki tüm ürünlerin tedarikçinizin listesinde olup olmadığını öğrenmek için lütfen aşağıdaki formülü kopyalayın veya H6 hücresine girin ve tuşuna basın. Keşfet sonucu almak için:

=EĞER(ISNA(DÜŞEYARA(30002,6 $ B $: 10 B $,1,YANLIŞ))"Eksik","Bulundu")

Veya formülü dinamik hale getirmek için bir hücre başvurusu kullanın:

=EĞER(ISNA(DÜŞEYARA(G6,6 $ B $: 10 B $,1,YANLIŞ))"Eksik","Bulundu")

√ Not: Yukarıdaki dolar işaretleri ($) mutlak referansları gösterir, yani aranan_aralık formülü diğer hücrelere taşıdığınızda veya kopyaladığınızda değişmez. Ancak, eklenmiş herhangi bir dolar işareti yoktur. lookup_value dinamik olmasını istediğiniz için. Formülü girdikten sonra, formülü aşağıdaki hücrelere uygulamak için doldurma tutamacını aşağı sürükleyin.

eksik değerleri bul 3

Formülün açıklaması

Burada örnek olarak aşağıdaki formülü kullanıyoruz:

=IF(ISNA(VLOOKUP(G8,$B$6:$B$10,1,FALSE)),"Missing","Found")

  • DÜŞEYARA(G8,$B$6:$B$10,1,YANLIŞ): aralık_bak YANLIŞ DÜŞEYARA işlevini tam olarak eşleşen değeri aramaya ve döndürmeye zorlar 3004, G8 hücresindeki değer. aranan_değer ise 3004 içinde var 1dizinin st sütunu 6 $ B $: 10 B $, DÜŞEYARA bu değeri döndürür; Aksi takdirde, #N/A hata değerini döndürür. Burada, dizide 3004 yok, bu nedenle sonuç şöyle olur: # N / A.
  • İSNA(DÜŞEYARA(G8,$B$6:$B$10,1,YANLIŞ)) = İSNA(# N / A): ISNA, bir değerin “#N/A” hatası olup olmadığını bulmaya çalışır. Evet ise, işlev TURE döndürür; Değer "#N/A" hatasından başka bir şey değilse, YANLIŞ döndürür. Yani, bu ISNA formülü geri dönecek ZELLİKLER.
  • EĞER(İSNA(DÜŞEYARA(G8,$B$6:$B$10,1,YANLIŞ)),"Eksik","Bulundu") = EĞER(DOĞRU,"Eksik","Bulundu"): ISNA ve DÜŞEYARA tarafından yapılan karşılaştırma DOĞRU ise EĞER işlevi Eksik, aksi takdirde Bulundu değerini döndürür. Yani formül dönecek Eksik.

EĞERSAY ve EĞER ile eksik değerleri bulun

Listenizdeki tüm ürünlerin tedarikçi listenizde olup olmadığını öğrenmek için EĞERSAY ve EĞER işlevleriyle daha basit bir formül kullanabilirsiniz. Formül, Excel'in sıfır (0) dışındaki herhangi bir sayıyı DOĞRU olarak değerlendireceği gerçeğinden yararlanır. Bu nedenle, başka bir listede bir değer varsa, EĞERSAY işlevi bu listedeki oluşumlarının sayısını döndürür, ardından IF sayıyı TURE olarak alır; Değer listede yoksa EĞERSAY işlevi 0 döndürür ve EĞER bunu YANLIŞ olarak alır.

Genel sözdizimi

=IF(COUNTIF("lookup_range",lookup_value),"Found","Missing")

√ Not: "Bulundu", "Eksik" değerlerini istediğiniz gibi değiştirebilirsiniz.

  • arama_aralığı: Karşılaştırılacak hücre aralığı lookup_value. Burada tedarikçinin ürün listesine atıfta bulunulmaktadır.
  • aranan_değer: EĞERSAY değeri, içindeki oluşum sayısını döndürmek için kullanılır. aranan_aralık. Burada listenizdeki ürünleri ifade eder.

Listenizdeki tüm ürünlerin tedarikçinizin listesinde olup olmadığını öğrenmek için lütfen aşağıdaki formülü kopyalayın veya H6 hücresine girin ve tuşuna basın. Keşfet sonucu almak için:

=EĞERSAY(EĞERSAY(6 $ B $: 10 B $,30002),"Bulunan","Eksik")

Veya formülü dinamik hale getirmek için bir hücre başvurusu kullanın:

=EĞERSAY(EĞERSAY(6 $ B $: 10 B $,G6),"Bulunan","Eksik")

√ Not: Yukarıdaki dolar işaretleri ($) mutlak referansları gösterir, yani aranan_aralık formülü diğer hücrelere taşıdığınızda veya kopyaladığınızda değişmez. Ancak, eklenmiş herhangi bir dolar işareti yoktur. lookup_value dinamik olmasını istediğiniz için. Formülü girdikten sonra, formülü aşağıdaki hücrelere uygulamak için doldurma tutamacını aşağı sürükleyin.

eksik değerleri bul 4

Formülün açıklaması

Burada örnek olarak aşağıdaki formülü kullanıyoruz:

=IF(COUNTIF($B$6:$B$10,G8),"Found","Missing")

  • EĞERSAY($B$6:$B$10,G8): EĞERSAY işlevi kaç kez yaptığını sayar. 3004, G8 hücresindeki değer dizide görünür 6 $ B $: 10 B $. Görünüşe göre, dizide 3004 yok, bu yüzden sonuç şöyle olurdu: 0.
  • EĞER(EĞERSAY($B$6:$B$10,G8),"Bulundu","Eksik") = EĞER(0,"Bulunan","Eksik"): EĞER işlevi 0'ı YANLIŞ olarak değerlendirecektir. Yani formül dönecek Eksik, ilk artırma YANLIŞ olarak değerlendirildiğinde döndürülecek değer.

İlgili işlevler

Excel EĞER işlevi

EĞER işlevi, Excel çalışma kitabındaki en basit ve en kullanışlı işlevlerden biridir. Karşılaştırma sonucuna bağlı olarak basit bir mantıksal test gerçekleştirir ve sonuç DOĞRU ise bir değer veya sonuç YANLIŞ ise başka bir değer döndürür.

Excel MATCH işlevi

Excel KAÇINCI işlevi, bir hücre aralığında belirli bir değeri arar ve değerin göreli konumunu döndürür.

Excel DÜŞEYARA işlevi

Excel DÜŞEYARA işlevi, tablonun ilk sütununda eşleşerek bir değer arar ve aynı satırdaki belirli bir sütundan karşılık gelen değeri döndürür.

Excel EĞERSAY işlevi

EĞERSAY işlevi, Excel'de bir ölçütü karşılayan hücre sayısını saymak için kullanılan istatistiksel bir işlevdir. Kısmi eşleştirme için mantıksal operatörleri (<>, =, > ve <) ve joker karakterleri (? ve *) destekler.


İlgili Formüller

Joker karakterlerle belirli bir metin içeren bir değer arayın

Excel'de bir aralıkta belirli bir metin dizesini içeren ilk eşleşmeyi bulmak için, joker karakterlerle - yıldız işareti (*) ve soru işareti (?) içeren bir İNDEKS ve KAÇINCI formülü kullanabilirsiniz.

DÜŞEYARA ile kısmi eşleşme

Kısmi bilgilere dayalı verileri almak için Excel'e ihtiyaç duyduğunuz zamanlar vardır. Sorunu çözmek için, joker karakterlerle birlikte bir DÜŞEYARA formülü kullanabilirsiniz - yıldız işareti (*) ve soru işareti (?).

INDEX ve MAÇ ile yaklaşık eşleşme

Çalışanların performansını değerlendirmek, öğrencilerin puanlarını derecelendirmek, posta ücretini ağırlığa göre hesaplamak vb. için Excel'de yaklaşık eşleşmeler bulmamız gereken zamanlar vardır. ihtiyacımız olan sonuçlar.

Birden çok ölçütle en yakın eşleşme değerine bak

Bazı durumlarda, birden fazla kritere göre en yakın veya yaklaşık eşleşme değerini aramanız gerekebilir. İNDEKS, KAÇINCI ve EĞER işlevlerinin kombinasyonu ile Excel'de hızlı bir şekilde halledebilirsiniz.


En İyi Ofis Üretkenliği Araçları

Kutools for Excel - Kalabalıktan Ayrılmanıza Yardımcı Olur

Günlük işlerinizi hızlı ve kusursuz bir şekilde tamamlamak ister misiniz? Kutools for Excel, 300 güçlü gelişmiş özellik getiriyor (Çalışma kitaplarını birleştir, renge göre topla, hücre içeriğini böl, tarihi dönüştür, vb.) ve senin için% 80 zamandan tasarruf et.

  • 1500 çalışma senaryosu için tasarlanmış olup, Excel problemlerinin %80'ini çözmenize yardımcı olur.
  • Her gün binlerce klavye ve fare tıklamasını azaltın, yorgun gözlerinizi ve ellerinizi rahatlatın.
  • 3 dakikada bir Excel uzmanı olun. Artık acı veren formülleri ve VBA kodlarını hatırlamanıza gerek yok.
  • 30 günlük sınırsız ücretsiz deneme. 60 günlük para iade garantisi. 2 yıl boyunca ücretsiz yükseltme ve destek.
Excel şeridi (Kutools for Excel yüklü)

Office Sekmesi - Microsoft Office'te Sekmeli Okuma ve Düzenlemeyi Etkinleştir (Excel dahil)

  • Düzinelerce açık belge arasında geçiş yapmak için bir saniye!
  • Her gün yüzlerce fare tıklamasını azaltın, fare eline veda edin.
  • Birden çok belgeyi görüntülerken ve düzenlerken üretkenliğinizi% 50 artırır.
  • Office'e (Excel dahil), Chrome, Firefox ve Yeni Internet Explorer gibi Verimli Sekmeler Getirir.
Excel'in Ekran Görüntüsü (Office Tab yüklü)
Yorumları sıralama ölçütü
Yorumlar (0)
Henüz derecelendirme yok. İlk değerlendiren siz olun!
Buraya henüz hiç yorum yapılmamış
Lütfen yorum yazın
Misafir olarak yayınlama
×
Bu gönderiyi değerlendirin:
0   Karakterler
Önerilen Konumlar

Bizi takip et

Telif Hakkı © 2009 - www.extendoffice.com. | Tüm hakları Saklıdır. Tarafından desteklenmektedir ExtendOffice. | | | Site Haritası
Microsoft ve Office logosu, Microsoft Corporation'ın Amerika Birleşik Devletleri ve / veya diğer ülkelerdeki ticari markaları veya tescilli ticari markalarıdır.
Sectigo SSL ile korunmaktadır